Thursday 14th February 2019

Crowd Control Version Update, scheduled 7 years ago

Hello! We will be performing a major update of all our Crowd Control services on Sunday 2/17 at 2AM EST. This update will be bring along a complete rework of Crowd Control in addition to new game support! Expected down time should be a few hours.

Please keep an eye on this page for updates.

If you continue to have issues, please contact us via our Discord, reach out on Twitter, post on our forum or email [email protected]!

Update: 5AM EST - Things are moving along and we are just about to launch our tests and move forward.
Update: 7:20AM EST - In our final phase of testing and working out a few kinks. We should be back live soon!

Update 9:02AM EST - Things are looking good! We are wrapping up a few things and will be pushing live any min now. Please contact us if you run into any issues~